Skip to content

extend full partitions on aix

By default AIX installs on several very small partitions, they fill up fast.

The good news is, they are easy to extend and no reboot or install media is required. Just use this to see what you have available:
# lspv hdisk0
# lspv hdisk1

Find out which partitions are full using:
# df -k
Filesystem    1024-blocks      Free %Used    Iused %Iused Mounted on
/dev/hd4           540672    0   100%     1622     1% /
/dev/hd2          2179072   0   100%    29351     6% /usr
/dev/hd9var        540672    0    100%      379     1% /var
/dev/hd3            32768     17188   48%       84     2% /tmp
/dev/hd1            16384     15820    4%       18     1% /home
/proc                   -         -    -         -     -  /proc
/dev/hd10opt        65536     11160   83%      856     6% /opt

Extend the partitions using:
# chfs -a size=1000M /dev/hd2 - Sets the size to 1000MB
# chfs -a size=+1G /dev/hd2 - Adds 1Gb to /dev/hd2
# chfs -a size=-1G /dev/hd2 - Removes 1Gb from /dev/hd2

Or set the partition size to a particular size (you can only increase sizes, not reduce):
# chfs -a size=500M /dev/hd4
# chfs -a size=1000M /dev/hd2
# chfs -a size=1000M /dev/hd9var
# chfs -a size=100M /dev/hd3
# chfs -a size=100M /dev/hd1
# chfs -a size=100M /dev/hd10opt

Post a Comment

You must be logged in to post a comment.